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TRAINING MANUAL 
 
Using data to evaluate housing markets 
 
1) Key Documents 
 

1. Strategic Housing Market Assessments: Practice Guidance (2007).  Available online at  
http://www.communities.gov.uk/documents/planningandbuilding/pdf/323201.pdf  

 
2. Local government publications – particularly more recent publications containing up to date 

findings (don’t let others’ research go to waste!) 
 

3. Policy documents as listed in guidance (see below) 

 
Strategic Housing Market Assessments: Practice Guidance (2007), p.16 
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2) Getting Started 
 

Software 

 
To freely explore all the data that is available access to as many of the following as possible is 
recommended:  
 
·  Geographical Information System Software (e.g. MapInfo1) 
·  SPSS 
·  Access 
·  Excel 
·  Internet access with download permissions 
·  Zip file software 
 
The above list is by no means exhaustive and new ways of manipulating data are being created all 
the time.   
 

Boundary Files 

 
As a Geographical Information System, to be able to produce useful information using Map Info 
you need to have access to boundary or point files so that the data can be linked to a location.  If 
these are not readily available, request them from your GIS staff or manager if necessary.  Key 
boundary files include: 
 
·  Regions 
·  Local Authorities 
·  ONS geographical boundaries – Super Output Areas, Middle Super Output Areas, Output 

Areas (see http://www.statistics.gov.uk/geography/census_geog.asp#oa ) 
·  Wards 
·  Parishes 
·  Postcodes (point or boundary files) 
·  Submarkets2 
 

Datasets 

 
Lists of data sources relating to each area of research are available throughout the Strategic 
Housing Market Assessments: Practice Guidance (2007).   
 
There are hundreds of different datasets available at a range of costs and accessibility levels. 
Obviously free data is the most cost effective. 
 
 

                                            
1 MapInfo will be the software used throughout this manual.  Other packages may use similar processes but users will 
need to refer to their user guide. 
2 Submarkets are ‘organic’ housing boundaries that reflect the choices and preferences of local people when they are 
active in housing markets.  Using local knowledge to create submarkets can help to make sense of data and identify 
trends.  This idea is discussed in the Local HMA Guide (2006), Chapter 2 pp.10-19 
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3) Downloading Census data 
 
Census data can be downloaded for most topics from the Neighbourhood Statistics page provided 
by the Office for National Statistics: http://www.neighbourhood.statistics.gov.uk/ . 
 
The ONS has provided a training section within their website which provides guidance on how to 
get the most out of the data:  
http://www.neighbourhood.statistics.gov.uk/dissemination/Info.do?page=userguide/onlinetraining/e
-learning-home.htm   
 

 
 
Generally the easiest way of finding the information you want is to view or download data by topic 
(via the link at the bottom left hand side).  If you are not sure about what a table contains you can 
view it online or click the blue icon.   �
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You will often be given a choice of geographic areas before you download.  To view data using 
Census geography (output areas), select NeSS Geography Hierarchy.  
 

 
 
Once you have found what you want, download the data (Excel is usually the easiest format to 
use), and make sure you save it in a place you can find again with a filename you can identify!  
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4) Cleaning the data 
 
Most datasets benefit from some cleaning which makes them smaller, easier to use and less likely 
to contain duplicates or misleading information.  Census tables contain a number of columns that 
can be deleted to make the file more manageable and easier to manipulate across other 
programs. 
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Cleaning data involves: 
 
·  Removing empty or unnecessary columns or rows 
·  Removing duplicates 
·  Ensuring data is organised in a friendly format (i.e. headings/categories across the top, 

reads across in rows). 
·  Ensuring consistent use of any categories, acronyms, codes or classifications so that you 

don’t end up with several categories for the same thing. 
 
An example of ‘dirty data’: 
 

   
 
Using the Autofilter  

 

All sorts of typos, duplicates and 
other random entries can find their 
way into datasets – since they are 
normally a system used for 
something else (i.e. a stock or 
waiting list), so entries are made 
frequently by different (and generally 
busy) people with different 
approaches or routines. 
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5) Geocoding Data 
 
It is normally possible to geocode most datasets providing you have a column in both the 
boundary file and dataset that can be matched.  Postcode is normally the best level of detail, 
though some datasets do go down to full address level (data protection must always be 
considered). Census data is a good example for geocoding as it is possible to map it at several 
different levels of geographical detail (region/local authority/middle super output area/lower super 
output area/output area): 
 
 

 
 
How to geocode a table: 
 

1. Open the relevant boundary file in MapInfo (e.g. Output Areas) 
2. Open the table you want to geocode (remember to tell MapInfo that it is in Excel format) 
3. Select which worksheet (if applicable) you want to open. 
4. Tick the box that says ‘Use Row Above Selected Range for Column Titles’ 
5. Open the browser 
6. Select Table > Geocode… 
7. Select the table you want to map by Geocode Table: 
8. Select the column you are matching against by using Column: 
9. Select the boundary/point file by Search Table: 
10. Choose icon/size/colour 
11. Geocoding will complete – you can see any records that have not been found through 

Query__Select… > Select Records from_Table: YOUR TABLE > that_Satisfy: not obj 
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1.  Open boundary file                                2.  Open file to geocode and select worksheet   
 

 
3.  Select Use Row Above Selected Range for Column Titles 
 

     
4.  Select Table > Geocode…                           5.  Select relevant options  
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6. Add the geocoded table to the map with right click > Layer Control… > Add… 

 
7. Geocoding is complete 

      
8. View unmapped rows using Query > Select… > Select Records from Table: YOUR TABLE 

> that Satisfy: not obj.  Tick Browse Results to view. 
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6) Extracting Geocoded data 
 
To simply extract geocoded data and view it in Excel, the quickest method is to use the Boundary 
Select tool:   
 

                                              
1.  Select Boundary Select Tool          2. Make sure that the mapped data is above the boundary   
                                                                layer in layer control  
 

 
3.  Click inside the boundary to select all data within it.   
 
 
Once you have selected your data you can view it in a browser or copy and paste it directly into a 
spreadsheet.  This function will not pick up column titles. 
 
Alternatively you can export the table into a CSV file from MapInfo. 
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1.  Select Table > Export…                                            2.  Select the data you have just highlighted 
 

 
3.  Save to relevant location as a CSV file.  Remember to change the file type…  
 

 
4.  Select ‘Use First Line for Column Titles’. 
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7) Using queries to select data 
 
Using queries in MapInfo can be a very useful way of extracting data in summary form.  An 
example of this is given below, though for complex queries or very large datasets a system like 
Access is normally more suitable. 
 
Example: Selecting the total population within urban areas 
 

1. Open the relevant boundary file (e.g. urban areas, parishes, submarkets etc.) 
2. Open the data you wish to examine (e.g. population age, house prices, empty homes etc.) 

 

 
3.  Go to Query > SQL Select… 
 

 
3. Set up query: 

1. Select tables: First the table you want to select data from, then the boundary table.  
You normally want the data to be Within the boundary file… 

2. Select Columns: First select the category you are aggregating to (e.g. urban 
area/LA/parish etc), then select your aggregate function (e.g. Sum, Count, Average 
etc), finally select which data column to aggregate from (e.g. Aged under 16). 

3. Select Group by Columns: enter the name of the column you want to aggregate to 
(e.g. I want to look at total working population by parish… group by “Parish Name”) 
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Queries take some getting used to and aren’t always the best way of manipulating data.  However 
they can be very useful in extracting summary information and in looking at data across different 
levels of geographical detail.  It is worth experimenting with a couple of datasets to see the 
different things you can do and to get accustomed to the logic behind creating queries. 
 
N.B: If you just want to add a column to the original table just select all the data within the relevant 
boundary file – although you will exclude data which is not within the boundary:   
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8) Using Microsoft Excel for Data Analysis 
 
Microsoft Excel has a multitude of different functions and uses, so an exhaustive list of uses is 
impossible.  However, a number of highly useful tools for data analysis are given below: 
 
 

Pivot Tables 

 
Pivot tables are a way of summarising and aggregating data without using MapInfo or SPSS.  
They can be useful for experimenting with datasets and finding indications quickly: 
  

 
1.  Select Data > PivotTable and PivotChart Report… 
 

 
2.  Check the data source is correct (you usually won’t have to change anything if your data is 
already open). 
  

 
3.  Select the data you want to look at.  Excel will normally automatically select all data in the   
worksheet you are viewing.  
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4.  Drag and drop categories into the table.  Double click on a pivot table field to change summary 
options. 
 
 

 
5.  It’s normally easiest to put the PivotTable into a new worksheet 
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6.  Once you have created your pivot table you can look at different aggregations of data and copy 
anything interesting or relevant into another area.  It is also possible to generate charts in this way 
using the PivotChart Report. 
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V Look Up 

 
The V Look Up function is very useful for matching up data from one place to another.  It can be 
used to find values to match codes, to look up values from a specific dataset, to set up housing 
profiles which allow the user to select specific areas and so on: 
 
Example: 
 
You have a list of ethnic group classification codes which you want to attach to the full description. 
 

  
1.  Select function > VLOOKUP 
 

 
2.  In Lookup_value, click on or enter the number of the cell which contains the value you want to 
find.  
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3.  Select the table which holds the data you are looking for. 
 
 

 
4.  Enter the number (counting from the first column) of the column you want to take values from.  
The Range_lookup box entry is always false – this means Excel will return a value of N/A# if no 
other value is found. 
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5.  Lock your table array if necessary (n.b. only do this if you want Excel to search in the same 
place each time).  
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6.  Copy the formula down your list to return all values.  Once you have entered all the values you 
can hard code over the formula (if necessary) by using the ‘Paste Special’ function 
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Access Paste Special using right click.  Select Values and only the formula result will be pasted. 
  
 

IF function 

 
The IF function can be used to enter a specific value into a cell if a certain condition is met (or not 
met).  It can be used to select most common groups, filter affordability levels, define specific 
characteristics etc. 
 
Example:  You want to select households whose incomes are above the estimated affordability 
threshold in a specific area. 
 

 
1.  Organise your data so that it is categorised according to the areas you are looking at (i.e. by 
parish/LA/output area etc).  Put the value of the condition you are testing for in the top row (i.e. 
Income category/classification) 
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2.  Create a table or column where you will enter the formula results  
 

 
3. Select  function key and IF function  
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4. Complete function arguments according to your specifications: 

1. Logical_test: This is the ‘IF’ box – enter the value or formula you are testing for.  i.e. 
‘IF’ 3.5 times this income is greater than 90% of the lower quartile price… OR ‘IF’ 
there are 81 or more flats in this area etc. 

2. Value_if_true/false: Could return a specific number (as in this example) or a definition 
or entry.  To return a blank entry enter empty quotation marks ( “” ) 

3. Ensure you lock cells so that they copy in the right direction and search in the right 
place. 

 

 
5.  Copy the formula across the table and aggregate the results as required.   
 
 
The IF function can be used on large spreadsheets to filter several different layers of data, but only 
a simple example has been used here to present the logic and functionality of it.   
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Other useful Excel functions 

 
Other handy tools in Excel include: 
 

CONCATENATE 

 
Joins text into one string – can be useful for creating full addresses e.g. Text1 = Address 1, Text 2 
= Address 2: Remember to put commas in between each entry if necessary 
 

QUARTILE 

 
Can be used to find the 1st, 2nd, 3rd or 4th quartile in a set of data.  Useful when looking at house 
price data, though remember to sort it into ascending order. 
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SORTING DATA 

       
Use Data > Sort.  Include Header row or reference column numbers.  You can sort specific 
patches of data if preferred… 
 

AVERAGE 
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9) Using Microsoft Word to format reports 
 
Formatting in Microsoft Word can be incredibly frustrating and time consuming.  Large documents 
can take a long time to update, changing one thing can set off automated changes everywhere 
else, things move around when you don’t want them to… 
 
Although there are some things you can do to try to avoid the extra work formatting creates, 
unfortunately there is no foolproof approach (as far as we know) to perfect report creation, so if 
you are working to a hard deadline, make sure you allocate some time for final formatting changes 
and editing. 
 
1.  Stop Word from automatically updating 
 

 
Select Tools > Templates and Add-Ins…    In the Templates tab, deselect Automatically update  

    document styles 
 
 
 
2.  Set up formatting for Headings/numbered lists/bullets etc 
 
Setting up how you want your document to look from the beginning doesn’t always work out, but it 
can help you to pick up when Word is doing something you don’t want it to.   
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Select Tools > Customize…                          In the Commands tab, go to Format, then drag the   
             style box up to your toolbar. 
 
 

Setting up formats 

 

  
Select Format > Styles and Formatting…      This brings up a formatting window on the right hand  
                       side.  
 



 28 

 

    
Select Show > Custom…        Select the formatting you want to use in your document.  Generally  

     leaving the Font/Paragraph/Bullet & Numbering formatting boxes   
     unchecked makes things simpler… 

 

 
You should end up with a simplified formatting box.  
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N.B.  This does not delete any of the other styles, just restricts the formatting changes you can 

make to text using this box.  You can always add formats to the text e.g.  
 

Setting up numbering 

 
Once you have established your formatting styles, you can set up a numbering hierarchy if 
required.  It is better to try to do this at the beginning if you can, as setting up numbering when you 
already have text in the document can cause Word to crash… it is still possible to do, just takes a 
little more time and patience. 
 
Let’s say you want the following hierarchy: 
 

1)  Heading 1 
 
1.1  Heading 2 
 
1.1.1  Heading 3 
 
1.1.1.a   Normal Text 
  
 
You can set it up in several ways.  The menu you want to access is the Outline Numbered list.  
You can get to it via: 
 

 
1.  Format > Bullets and Numbering… 
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OR 2.  Right click style on formatting window                Select Format > Numbering… 
and select Modify…                         
 
 

                                                
OR 3.  In formatting window select          Select Styles… 
Show > Custom… 
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Select relevant style and Modify…            Select Format > Numbering… 
 
 
 
 
 
ALL 3 OF THESE ACTIONS WILL BRING YOU TO THE SAME MENU: 
 

 
Select Outline Numbered tab 
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Select the box closest to what you want and click Customize… 
 
 

 
 
Here is the dreaded Customize Outline Numbered List setup box.  This is what it looks like as 
soon as you hit the Customize button on the previous menu.  The next screenshot shows the 
setup after the desired changes have been implemented…   
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Applying Formatting as you type 

  
If you decide you want to make something a heading you can: 
 

 
Highlight the text and apply the formatting from the formatting window… 
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Use the drop down formatting box from your toolbar (if added…) 
 

 
Select your customized Outline Numbered list from the Format > Bullets and Numbering… menu 
 
If you have a heading that you want to change to a different style (i.e. make it a Heading 3 instead 
of a Heading 2 etc, you can use right click > increase/decrease indent (it is also possible to add 
these options to your toolbar from the Tools > Customise menu…).  You can also restart or 
continue numbering from the right click menu. 
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You can also tweak style spacing quickly in the Modify Style menu  
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Remember to TELL WORD what you want; don’t let Word decide your formatting for you.  
Whenever Word starts automatically applying formats you don’t want, clear the formatting and 
start again (Clear Formatting is normally an option on the formatting window, or go to Edit > Clear 
> Formats). 
 
Don’t forget to SAVE your work often! (This may be stating the obvious but it is the best way to 
avoid losing work through a crash…) 
 
You can always LOCK the formatting in a file as follows: 
 

             
Go to Tools > Protect Document…                         Set up formatting restrictions via Settings… 
 

 
Select the styles you want to use 
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Creating a Table of Contents 

 
To create a Table of Contents go to Insert > Reference > Index and Tables… 
 

 
 

 
In Table of Contents tab, check the set up in Options… and Modify…  
 

 
In the Options box, select the different levels of listing you want in your TOC. 
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In the Modify box, set up the style you want each level of your TOC to have 
 
Once you are happy, click OK – Word will generate a Table of Contents based on the styles you 
have selected.  If it picks up any random entries, they have probably inadvertently been assigned 
to styles where they are supposed to be normal text.  Find them in the document and 
remove/change their formatting.   
 
When you have a completed Table of Contents, you can update it using right click > Update Field 
 

    
Right click > Update Field               Select appropriate option 
 
 

Creating an Index 

 
A concordance file is the best and easiest way of creating an index, and with any luck is a piece of 
work that can be recycled (to some extent).  Instructions on how to create and use a concordance 
file are available in Word Help under ‘Create an index’.   
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Inserting images or charts in Word 

 
You can simply copy and paste images into Word, either straight from the folder or from a 
spreadsheet.   
 
Go to Insert > Picture > From File… then browse to your picture. 
 
If you have a folder open with pictures you can simply copy the file and paste it straight into your 
document as a picture: 

  
Copy the file in the folder and paste it straight into your document.  Edit the picture using right click 
– you can trim it with the ‘crop’ tool in the picture toolbar, or change the size in the Format Picture 
menu. 
 

Inserting Captions 

 
If you want to number your maps/charts/tables etc use captions – you can link the numbering to 
your chapter numbers and they should automatically update. 
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10) Keyboard Shortcuts 
 
Knowing your keyboard shortcuts is a great way of saving time, and most of them work across 
most applications.  Here are some favourites: 
 

 = Access Start menu (use arrow keys to navigate) 

 = Access menu toolbar (e.g. File/Edit/View/Insert etc) 

= Exit menu 

= Go to start of line/row 

= Go to end of line/row 

= Refresh 

=Full screen view 

= Overwrite on/off (allows you to type straight over your text)  

 + = Switch between applications  

+ = Go to start of document 

+ = Go to end of document 

+ = Take screenshot  

+  = Copy 

+ = Find  

+ = New document 

+ = Open document 
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+ = Print document 

+ = Save document  

+ = Paste 

+ = Cut 

+ =Undo 

+ + =Change font size 

+ or = Switch between worksheets (Excel only) 

+ = Highlight/Select to end of line/row 

+ = Highlight/Select to start of line/row 

+ ARROW KEYS to select text/cells 

+ + ARROW KEYS to select whole rows/columns  
 
 
You can also customize your own keyboard shortcuts easily in Word using Tools > Customize…: 
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11) Links to useful web-based resources3 
 
Online training videos (B.Line Housing Information):  
 
Create a pivot table: 
http://www.blinehousing.info/Camtasia/Training/Create_pivot_table/Create_pivot_table.html  
 

Create a thematic map: 
http://www.blinehousing.info/Camtasia/Training/Create_Thematic_Map/Create_Thematic_Map.ht
ml  
 

Extract geocoded data:  
http://www.blinehousing.info/Camtasia/Training/Extracting_geocoded_data/Extracting_geocoded_
data.html  
 

Geocoding: http://www.blinehousing.info/Camtasia/Training/Geocoding/Geocoding.html  
 

Using the MapInfo query function: 
http://www.blinehousing.info/Camtasia/Training/Using_query_function/Using_query_function.html  
 

ONS Training videos: 
http://www.neighbourhood.statistics.gov.uk/dissemination/Info.do?page=userguide/onlinetraining/e
-learning-home.htm  
 
Department for Communities and Local Government homepage: 
http://www.communities.gov.uk/corporate/  
 
Neighbourhood Statistics – Census data: http://www.neighbourhood.statistics.gov.uk 
 
Understanding your housing market (CCHR, DeMontfort University with B.Line and Housing 
Vision) – contains several useful links to data: 
http://www.blinehousing.info/NHF_Understanding_your_housing_market.htm  
 
Hometrack Housing Intelligence System: http://www.hometrack.co.uk/housing_intelligence.aspx 
(requires purchase) 
 
UK Statistics Authority: http://www.statistics.gov.uk/ 
 
Government Offices for the English Regions: http://www.gos.gov.uk/national/  
 
Regional Assembly websites: 
 
East of England Regional Assembly: http://www.eera.gov.uk/  
East Midlands Regional Assembly: http://www.emra.gov.uk/ 
London: http://www.london.gov.uk/  
North East Assembly: http://www.northeastassembly.gov.uk/  
North West Regional Assembly (Technical website): http://www.nwrpb.org.uk/ 
South East England Regional Assembly: http://www.southeast-ra.gov.uk/  
South West Regional Assembly: http://www.southwest-ra.gov.uk/  
Yorkshire and Humber Assembly: http://www.yhassembly.gov.uk/  
West Midlands Regional Assembly: http://www.wmra.gov.uk/  
 

                                            
3 N.B. Links may expire – last updated 28 August 2008  
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Government Actuary’s Department: http://www.gad.gov.uk/Demography%5FData/  
 
Department for Environment, Food and Rural Affairs: http://www.defra.gov.uk/  
 
Commission for Rural Communities: http://www.ruralcommunities.gov.uk/  
 
NHS Information Centre: http://www.ic.nhs.uk/  
 
Mid Year Estimates: http://www.statistics.gov.uk/statbase/Product.asp?vlnk=15106  
 
Nationwide Building Society House Prices: Data Download 
http://www.nationwide.co.uk/hpi/historical.htm  
 
Department of Work and Pensions – National Insurance Number allocations: 
http://www.dwp.gov.uk/asd/tabtool.asp#ni_alloc  
 
Council of Mortgage Lenders statistics: http://www.cml.org.uk/cml/statistics  
 
UK Housing Review (University of York): 
http://www.york.ac.uk/res/ukhr/ukhr0708/compendium.htm#profiles  
 
International Passenger Survey: 
http://www.statistics.gov.uk/ssd/surveys/international_passenger_survey.asp  
 
ONS Population Estimates: http://www.statistics.gov.uk/StatBase/Product.asp?vlnk=601  
 
Annual Survey of Hours and Earnings: 
http://www.statistics.gov.uk/StatBase/Product.asp?vlnk=13101  
 
Survey of English Housing: 
http://www.communities.gov.uk/housing/housingresearch/housingsurveys/surveyofenglishhousing/  
 
Housing Strategy Statistical Appendix: 
http://www.communities.gov.uk/housing/housingresearch/housingstatistics/housingstatisticsby/loc
alauthorityhousing/dataforms/  
 
London School of Economics Research Lab Data Service: http://rlab.lse.ac.uk/data/default.asp  
 
Projecting Older People Population Information System (POPPI): 
http://www.poppi.org.uk/index.php?pageNo=330&areaID=8439  
 
 
 
 


